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MGDS Data Exploration Tools – Hands-on exercises and usability feedback 

 
Please try the following short exercises. Remember, there are multimedia tutorials and help pages at 
this web page: http://www.geomapapp.org/ 
 
 
GeoMapApp: Search for geochemical signatures using PetDB petrology 
 
Zoom to the EPR 9N Integrated Study Site. Most of this seafloor is mapped with high-resolution 
multibeam; fuzzy areas around the edges are the background satellite altimetry-derived bathymetry.  
 
Load the PetDB samples chemistry (Focus Sites -> Select From Searchable List, type “MORB” into 
search box, click once on EPR Rock samples and MORB chemistry from PetDB, then hit OK). When 
the table is loaded, use the Colour By Value button to colour the symbols on, say, MgO. In the colour 
palette window, slide the grey lines sideways to change the colour scale. Use the Graph button to plot 
FeOT against MgO. In the graph plot window, click on the Lasso tool and use the mouse to encircle 
the high-MgO outliers. This lights up the symbols both on the graph and in the map window.  
 
Bonus: On the right, use the Save drop-down menu to copy the selected points into an Excel 
spreadsheet and open the spreadsheet. 
 
Note: you can also pull up these samples using the real-time PetDB Web Feature Service, as follows. 
File -> Import Dataset from WFS. From the drop-down menu, select PetDB, hit Connect. Hit Load 
Feature (may take a few minutes depending upon the internet connection). 
 

 

http://www.geomapapp.org/
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GeoMapApp: Central America geochemical signatures using EarthChem petrology 
 
Zoom to the Central America area. Land elevations are from the Space Shuttle SRTM90 mission. 
Seafloor depths are from high-resolution multibeam and background satellite altimetry-derived 
bathymetry.  
 
Load the EarthChem samples chemistry (Focus Site -> Select From Searchable List, type 
“earthchem” into search box, click once on EarthChem Rock Samples Central America, hit OK). Use 
the Colour Symbols button to colour the symbols on, say, CaO. In the colour palette window, slide the 
grey lines sideways to change the colour scale. Use the Graph button to plot TiO2 against SiO2. Click 
on map points or table records to highlight particular samples.  
 
In the graph plot window, click on the Lasso tool and use the mouse to draw a line on the graph 
around the high-TiO2 samples. This lights up the symbols both on the graph and in the map window.  
Bonus: On the right, use the Save drop-down menu to copy the selected points into an Excel 
spreadsheet and open the spreadsheet. 
 
Note: you can also pull up the ocean floor samples using the real-time PetDB Web Feature Service: 
File -> Import Dataset from WFS. From the drop-down menu, select PetDB, hit Connect. Hit Load 
Feature (may take a few minutes depending upon the internet connection). 
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GeoMapApp: Biological diversity and high-resolution bathymetry at hydrothermal vents 
 
First, load the high-resolution ABE Imagenex 5m bathymetry grid for the EPR:9N ISS (Places -> 
Hi_Res_Grids -> EPR_9N -> 9 50). Use the zoom button to zoom in on the bathymetry. In the Grid 
Options window, click on the Profile Tool and use the mouse to select a profile line. 
 

   
 
Load Alvin dive photos as follows: Available Data -> Open Searchable List. Type “dive photo” in the 
text box at the top, click once on EPR:9_50N NDSF Dive Photos so that only this item remains 
highlighted. Hit OK. In the Layers window, click once on the EPR_9_50N item in the left pane and 
then click the Layers window + zoom-in button to zoom to the EPR 9N area. The squiggly lines are all 
dive tracks in this area. In the right Layers window pane, scroll down and select Alvin dive number 
3973. Click the yellow light bulb button to produce a list of FrameGrabber photos for this dive. This 
also plots the locatiojn of each photo as a circle on the dive track. Click the yellow light bulb button 
twice more to bring up two photo windows. In one of these photo windows, select Camera 2 from the 
drop-down menu. Use the Left and Right arrows to scroll through the photos. Jump down to photos 
with time stamp 20040216_194753 and scroll forwards to see Riftia (tube worms), crabs and 
anemones at Tica vent.  

 
 



MGDS-GeoMapApp Exercises, January 2009 

Page 4 of 16 

 
GeoMapApp: Earthquake swarms at the Wilkes fracture zone 
 
Open the NOAA PMEL earthquake catalogue for the EPR area (Portals -> Location and Timing of 
Seafloor Earthquakes and Volcanic Eruptions. Select EPR, hit OK). The lower pane shows a 
histogram of number of earthquakes against time (year, day, date).  
 
Zoom to the Wilkes fracture zone at 109ºW/9ºS. The spikes in the earthquake histogram at the 
bottom show two swarms in the six-year. Reduce the movie speed to, say, 4 frames/sec (lower left 
corner). Play.  
 

 
 
The spectacular abyssal fabric which curves into the FZ can be best seen by unticking the plot box 
(lower right). To save the movie, select Save and add “.mov” to the filename. It can then be played on 
your iPod! 
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MGDS Ridge 2000 data portal: Find samples, stations and deployed instruments 
 
Use the MGDS Ridge 2000 data portal to view maps and current vent information at each Integrated 
Study Site. On the main MGDS web page (http://www.marine-geo.org/), under Data Portals select 
Ridge 2000. Click on the interactive map, select the Samples tab and zoom in. Click on a sample 
symbol to display the sample and cruise name. Click the Stations tab to view stations. Download or 
view a list of currently-deployed instruments as follows. In the left pane, under List Data by Site, open 
the drop-down menu and select the ISS. Scroll down in the left pane and click Deployed Instruments. 
 

 
 
Samples and stations can be viewed interactively in GeoMapApp (see example 7), and the table of 
currently-deployed instruments can be imported. 

http://www.marine-geo.org/


MGDS-GeoMapApp Exercises, January 2009 

Page 6 of 16 

 
MGDS Ridge 2000 data portal: View a map and list of hydrothermal vents for each ISS 
 
Use the MGDS Ridge 2000 data portal to view maps and current vent information at each Integrated 
Study Site. On the main MGDS web page (http://www.marine-geo.org/), under Data Portals select 
Ridge 2000. Click on the interactive map, select Vents and zoom in. Click on a vent symbol to display 
the vent name. Download or view a list of vents as follows. In the left pane, under List Data by Site, 
open the drop-down menu and select the ISS. Scroll down in the left pane and click Vent Locations. 
 

 
 
 
 
MGDS: Download Temperature probe data for the EPR 9-50N hydrothermal vents 
 
Use the MGDS Search For Data interface to search for and download data, as follows. Open Search 
For Data (http://www.marine-geo.org/, under Tools & Services). In the Select Data By drop-down 
menu, choose By Device Type and in the Device Type drop-down menu select Probe:Temperature. 
Hit Search. Click on the two entries EPR:9N_LoTemp and EPR:9N_HiTemp, and, in each, click the 
Temperature hyperlink to download the temperature data for individual vents. 
 

http://www.marine-geo.org/
http://www.marine-geo.org/
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GeoMapApp: Plot instrument and sample locations in the Lau Basin using WFS 
 
Connect to the Ridge 2000 database using the MGDS Web Feature Service (File -> Import Dataset 
from WFS, select MGDS, hit Connect). Select Stations:World,location Ridge2000:Lau Basin, hit Load 
Feature. Zoom to the Lau Basin area. Select a station (either click on map dots, or click on rows in 
table). To select more than one row, use the shift or control keys. 
 
To view the full database entry for this locality scroll to right side of table and click on the Details URL 
to bring up MGDS web page. 
 

 
 
 
Bonus: Use the Lasso Tool to select some stations and save the station information to an Excel 
spreadsheet (Save button on right, Selection to Excel File).  
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GeoMapApp: Examine multi-channel seismic profiles across the Aleutian Trench 
 
Load the multi-channel seismics interface (Portals -> Multi-Channel Reflection Profiles, then hit OK). 
Click the box over the Aleutian subduction zone. This zooms in to the area. Click the trench-
perpendicular southwestern-most seismic line (line 1232 on cruise EW9409). Push the view-1 button 
to load the profile. Scroll down to see the horizons. Use the zoom button on the left of the profile pane 
to see more detail. The red section of line in the map view depicts the portion of the profile in the 
display pane. 
 
Now select the trench-parallel profile (line 1234, EW9409) intersecting this line and load in view-2. 
Click the triangular dots icon to digitise discrete points on the horizons (left-click to digitise, right-click 
or diskette symbol to copy digitised points). Click the T icon to add text labels. 
 
Bonus: view profiles in inverse video (select black/white square icon), side-by-side (select Horizontal), 
and compressed (use compress icon on left). 
 

 



MGDS-GeoMapApp Exercises, January 2009 

Page 9 of 16 

 
GeoMapApp: A decade of earthquakes in the IBM Focus Site – accessing data with WFS 
 
Zoom in to the IBM area. Connect to IRIS (seismology repository) using the IRIS Web Feature 
Service (File -> Import Dataset from WFS, scroll down and select IRIS, hit Connect). Select the 
feature topp:Events1990to2000 for the Current View bounding box, hit Load Feature. Colour the 
symbols according to magnitude, and scale the symbols according to depth. Note that clicking in the 
table on the URL hyperlinks brings up the IRIS Wilber II information window. Save the image as a 
KMZ file on the desktop and double-click the file icon to open Google Earth. 
 

 
 
 
MGDS: Download CTD-BLISP data for Papua New Guinea Source-to-Sink initiative 
 
Use the MGDS Search For Data interface to find data (http://www.marine-geo.org/, under Tools & 
Services). In the Select Data By drop-down menu, choose By Device Type and in the Device Type 
drop-down menu select CTD. Refine the search further by limiting results to the PNG area (under 
Search Location By select Focus/Study Site, and in the Focus/Study Site drop-down menu choose 
PNG). Hit Search. Click on the hyperlink for, say, VANC19MV. Scroll through list to find BLISP data 
and processed (level 2) CTD data. Click on link to download file.  
 

 

http://www.marine-geo.org/
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GeoMapApp: Import Weinrebe bathymetry compilation grid of Central America 
 
Use the search capability in Search For Data (http://www.marine-geo.org/, under Tools and 
Services) to find the Central America bathymetric compilation grid of Weinrebe. (Hint: search on 
Investigator name and/or search location by Focus Site.) Click on link to file name 
CR_all_new_0.002_0.002_z.grd to download the file. Unzip the file. 
 
Import this grid to GeoMapApp (File -> Import a 2-D Grid file). Once imported, use the zoom buttons 
to explore this multibeam grid. Use the Grid menus to change the colour palette (slide the grey lines 
sideways), alter the sun angle, and increase the vertical exaggeration. You can also change the 
colour histogram using the vertical sliders. 
 
Bonuses: to see how this grid compares to the underlying background bathymetry, turn the imported 
grid off and on by clicking the “visible” box in the Layers window. In the Grid menu, draw contours, 
change the sun illumination angle, increase the vertical exaggeration, and save image as a JPEG file.  
 

 
 

http://www.marine-geo.org/
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GeoMapApp: Explore contributed bathymetry grids 
 
In the GeoMapApp toolbar, click the Show Contributed Grids (rectangles) icon. Zoom to the IBM area 
and click once on the box marked Marianas Western Insular Margin (2006-2007). That box is now 
highlighted. Right click in the box. The grid will load automatically, and a Layers and Grid Layer 
Dialog window will each open.  
 
Use the zoom buttons to explore this multibeam grid. Use the Grid menus to change the colour 
palette (slide the grey lines sideways), alter the sun angle, and increase the vertical exaggeration. 
You can also change the colour histogram using the vertical sliders. Note that the rectangular outlines 
of the contributed grid bounding boxes can be discarded by clicking again on the Show Contributed 
Grids icon. 
 
Bonuses: to see how this grid compares to the underlying background bathymetry, turn off and on the 
high-resolution multibeam grid by clicking the “visible” box in the GeoMapApp Layers window. 
Change to a black-and-white colour palette (Palettes button in Grid Dialog box), and save this image 
as a JPEG file.  
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MGDS MARGINS data portal: Find samples and stations for each Focus Site 
 
Use the MGDS MARGINS data portal to view maps and current station/sample information. On the 
main MGDS web page (http://www.marine-geo.org/), under Data Portals select MARGINS. Click on 
the interactive map, select the stations tab and zoom in. Click on a station symbol to display the 
station and field program name, and, in the information bubble, click those links to view the full 
MARGINS database entry. Click the samples tab to view samples. 
 

 
 
Samples and stations can be viewed interactively in GeoMapApp (see example 7), and the table of 
currently-deployed instruments can be imported. 

http://www.marine-geo.org/
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GeoMapApp: Plot the location of Waipaoa sediment cores – the MGDS WFS 
 
Connect to the MARGINS database using the MGDS Web Feature Service (File -> Import Dataset 
from WFS, select MGDS, hit Connect). Select Stations:World, location MARGINS:New Zealand, hit 
Load Feature. Zoom, select a core (click on map dots, or click on rows in table) and view the full 
database entry for core (scroll to right side of table, click on URL to bring up MGDS web page). 
 
Bonus: Use the Lasso Tool to select some cores and save the core station information to an Excel 
spreadsheet (Save button on right, save Selection to Excel File).  
 

 
 
 
8) MGDS: Download MARGINS-funded multibeam swath files for Gulf of California cruises 
 
Use the MARGINS data portal to find data (http://www.marine-geo.org/, under tab Data Portals, 
MARGINS). In the List Data by Site drop-down menu, choose Gulf of California. Under MARGINS 
Data Sets, choose by Data Type and scroll down the resultant list to the bathymetry hyperlinks. 
Follow links to examine the swath file listings and to download data. Bonus: Download MGD77-
formatted ASCII file containing gravity and magnetics data. 
 

 

http://www.marine-geo.org/
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GeoMapApp: Compare gravity-magnetics- topography profiles along ship tracks 
 
Load the underway geophysics interface (Portals -> Bathymetry, Gravity, and Magnetic Anomaly 
Profiles). Zoom in, click on a track or use lower left cruise ID menu to select track (example: select 
RC2608). Hit View Profile. Red part of track line shows the extent of the displayed profile. Use scroll 
bar at bottom to scroll through profile. Click circles to switch between bathymetry, gravity and 
magnetics. Use lower left Download Data to get the MGD77 file. 
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Tear-Off menus 
 
There are two ways to get to the built-in GeoMapApp data sets. The first way allows users to select 
items from the drop-down menus. These need to be invoked for each data set loaded. Example: 
 

 
 
The second way allows any drop-down menu to remain open and active throughout a GeoMapApp 
session. This means that multiple data sets from one menu can be loaded without having to go back 
through the drop-down menus. To invoke this, go into the Basemaps, Datasets or Focus Sites tab 
and hit Select From Searchable List. In that window, navigate to any menu. Click either the folder 
symbol or menu name and drag the mouse out of that window. The menu selected will open in a new 
window. Any sub-menus are fully active. To select a data set, click on it and hit OK. 
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